A new Critical Remote Code Execution Vulnerability (CVE-2022-1329) as been discovered in Elementor, a popular and powerful tool used in the building of WordPress sites.

Hire Cybersalt to manage your WordPress site!If you are subscribed to one of Cybersalt's monthly management packages, rest assured that we have already updated and secured your site against this vulnerability.

Interestingly, the firewall company that discovered this vulnerability on March 29, 2002 immediately added an alert for their paying clients, but those using the free, lighter version of their tool will not begin to receive alerts for CVE-2022-1329 until April 28th, 2022. That's a reminder that free could cost you greatly when it comes to the security of your digital assets. We are honoured by the investment and trust you have placed in Cybersalt to watch over these things for you.

If you wish to know more about this vulnerability, or if you have opted to manage your website site security and updates yourself, you can read more about CVE-2022-1329 through the following link:

www.wordfence.com/blog/2022/04/elementor-critical-remote-code-execution-vulnerability